Ready Maker's all assets missing

Hi, I use Ready Maker for teaching game design to children, and it’s a great program for that.

However there is a problem that has lately made it very difficult:
Randomly, at times, when I or anyone of my students open the program, the + sign gives only a few categories, with all the object and visual categories completely missing. When this happens, you can’t even upload your own assets to use in their place. This means when this happens to someone, they cannot do anything in that lesson, since you can’t do much wihtout a single object in this program.

I have 10 iPads we use, and this happens to at least 2-3 of them every single day, so it’s a real issue to me. Does anyone know what is going on, is there a fix? It’s not about the connection to the internet, we’ve tried that in a dozen different ways…

2 Likes

Hmm, that’s odd, may try uninstalling and reinstalling? Maybe @admin can help you out here.

2 Likes

Hey @JaakkoV! Welcome to our community! :mechanical_arm:

The error you described indicates that you cannot connect to our servers (They are located in North America). Unfortunately, we cannot influence this in any way, since these are problems associated with foreign traffic. Similar problems began with the onset of the coronavirus pondemic.

It’s really difficult for me to recommend you anything, probably the volume of foreign Internet traffic you have is limited, this explains the fact that some of the students can connect to our servers, and the other part cannot. As a rule, these problems most often arise for users from Eastern Europe and they are temporary (Depends on how foreign traffic is established from your Internet provider).

I hope that after some time these problems will not be repeated, but from our side we can hardly help you with anything.

Please tell me which region you live in, we will try to track users from your region and if we manage to find good advice for you, we will inform you about it. Thanks!

What technical problems could there be?

  • I’m not sure, but also try to always clear the cache before starting the lesson (Open Ready Maker/Settings/Tap to “Clear Cache”)
  • Try close another all apps on the your IPads
  • Clean up RAM
2 Likes

@JaakkoV welcome to the ready maker forum. I agree with what @Ready said. I also believe that the problem you described has to do something with foreign internet traffic, cache or background app/memory.

As a matter of fact, I have myself experienced such issues, but these are temporary, and it turns out that the problem automatically resolves within 24 hours. So I would recommend you to wait for about a day and check again.

Also, you might want to try out Ready Maker on a PC or Android if possible.

1 Like

Thank you all for your responses!

I understand that it’s likely not something within your power right now… I’m located in Eastern Finland, so likely part that Eastern Europe-problem group.

I’m using Ready also on my Windows PC laptop, and it too has the same issue at times, actually just an hour ago. This time closing and opening the program helped, but one of my students had it too and restarting didn’t help him.

Narrowing it down the internet traffic may help, we’ve been using all the 10 ipads with wi-fi shared from my phone, perhaps putting less pressure on a single mobile wi-fi might do something.

Thank you for the tips, I’ll try them all out. I’ll be sure to tell it to you here if we find a solution.

This problem is really unfortunate, otherwise Ready is just perfect for getting to know game design basics through creating your own games.

2 Likes

Yesterday the problem was pretty bad at the start, six of my ten iPads had it, plus my laptop.
I tried a combination of clearing the cache, disconnecting and reconnetcing to wifi and restarting Ready, which actually helped some devices, three of the six started working that way. So I don’t know what did it exactly, but it has chance of removing the problem on the spot. The other three still didn’t work, but knowing this does help me already!

2 Likes

Hi JaakkoV

I am also teaching Ready Maker to Ge=rade VIII and IX students in Pakistan and faced same problem especially after signing in and out of so many accounts for each class on tablets
I found a quick fix which may work for you also

Whenever you cannot see the assets do this…
Use Upload Assets to upload any image toyour Ready Maker account
Your artwork will come back or else do it again

2 Likes

Hi Sheba, that’s very interestring, I’ll give that a try! For now what has quite often removed the problem has been closing Ready, disconnecting and reconnecting to wifi and then opening Ready again. But it’s good to have many tricks ready!

2 Likes

I am in Grand Prairie, Texas and my students have the same issue. I would love to know if there is a set of servers that our school district needs to whitelist on the security profile and if that would help

4 Likes

Could this help you out?

1 Like

This could be helpful @greenreader9 but for one or two days, Ready Maker might not work

Good news, I hope they can find a way to improve them!

1 Like

Hi, I still have these problems “+ sign gives only a few categories”.
Even when the art category is visible, I cannot add any object to the canvas. I can add an object but it’s not visible. I have reinstalled the application, same results.

1 Like

When I have either of those problems, and out of my 12 devices always at least three have it, I do the following:

  • Sign out the user, and close Ready Maker
  • Disconnect from internet
  • Restart the device
  • Reconnect to internet
  • Open Ready and sign back in

That has about 50% chance to fix the problem. If it doesn’t, the only solution seems to be to wait and try again later.

2 Likes