Help, Game not importing to Unity correctly

Hello!
I am trying to create a new build of my game, but when I import the new version into unity, I get an error, and the game does not play properly. I am using the same version of unity I used for my first build of the game last year (2019.4.16f1), so I don’t know what is going on!
Attached below are two videos, one of the game working properly in Ready, and the other of the error in unity.
Thanks for your help!

Video #1: 20210403_124917.MP4 - Google Drive

Video #2: 20210403_124552.MP4 - Google Drive

1 Like

Ok, I tried again using Unity 2019.2.12f1 (I re-exported from Ready), and I get the following error:

NullReferenceException: Object reference not set to an instance of an object
KVirtualJoystick.SetColor (UnityEngine.Color color) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
K8DirectionMoveBehavior.PropertyUpdated (System.String propertyName) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBehavior.PropertiesUpdated () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBehavior.SetRuntime (System.Boolean running) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KObject.SetRuntime (System.Boolean isRunningFlag) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBaseEnviromentManager.Run () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBaseEnviromentManager+d__75.MoveNext () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at C:/buildslave/unity/build/Runtime/Export/Scripting/Coroutines.cs:17)
Also, the same thing happens as in Video #2 above, where the game is incorrectly displayed, and while the button seams to work, it does not start the game.

@Ready, is there a bug or something here, or is some settings messed up?
Thanks!

1 Like

Ok, tried again in Unity 2019.4.8f1 (After a Ready Re-Export), and this error occurs:

NullReferenceException: Object reference not set to an instance of an object
KVirtualJoystick.SetColor (UnityEngine.Color color) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
K8DirectionMoveBehavior.PropertyUpdated (System.String propertyName) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBehavior.PropertiesUpdated () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBehavior.SetRuntime (System.Boolean running) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KObject.SetRuntime (System.Boolean isRunningFlag) (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBaseEnviromentManager.Run () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
KBaseEnviromentManager+d__75.MoveNext () (at <1710231fc3234d4f8df9a2a4a2f22bdc>:0)
UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <2feaf16e80004e0cadae3f2e05f2a3fa>:0)

Thanks again for any help!

2 Likes

Hi @greenreader9! You need use the “Unity 2019.2.12f1” version for the export now. I can see error with Joystick color, you can try maybe not use the color for the joystick?

If this not help for you, you can send me link of the your project to this topic, i will try check him.

1 Like

Hi @Ready
I was able to get the scene to open in Unity, however, I now have a different issue.
The control pad for the eagle (Player) does not show fully on the screen in Unity, but does in Ready. My scene is set to “16:9 Portrait (9:16)” in Unity, so I dont know what is happening.
Thanks!

Images:
LEFT: ReadyMaker
RIGHT: Unity

2 Likes

Hi @greenreader9 ! There is nothing terrible here, it can sometimes happen for the Unity player, try to create a new build for PC or Android, most likely the joystick will fall into place

1 Like

Thanks for your answer, and now this is getting frustrating. I made a new export from Ready, clicked the “add” button in Unity Hub and added the folder. Selected 2019.2.12f1 and “Android”. Opened the project.

And the error:
The unity icon shows partly green, like its loading
Icon
And in Unity, a “Compiling Shader ‘Skybox/Procedural’” blue loading bar


Try to double click the UnityPackage file? A “Open With” window appears

What the going on? And why won’t Unity ever work for me when I’m using Ready projects (besides the very first time)?
@Ready @Dravin @Anyone Can you help?
Thanks!

Oh, once before (the day I posted above) I did get it open, and was able to export it. However, Google Play Console gave a multi-line error (I was only able to capture one line)
“Your APK or Android App Bundle needs to have the package name com.COMPANYNAME.TheFlyingEagle.”

2 Likes

Hi @greenreader9 ! This error means that you entered the wrong name for the “Package Name”. Try to repeat the settings for the apk file as shown in this video: Export the “Ready” project to the “Google Play” - YouTube

1 Like

Hello,
I watch the video above, and those are the steps I did. I did do it again, and recorded a video. After I got the same error, and realized it was basically a 8 minute video of loading bars, I just screenshotted the main points.

  1. Export from Ready to a new folder

  2. Open Unity Hub, Click “Add” and choose the folder. Select the 2019.2.12f1 editor version, and Android.

  3. Open the project.

  4. This appears, I click “Continue”

  5. a bunch of loading bars display with various messages.

  6. The editor loads

6a. The arrow on the left points to the package file, and the arrow on the right points to the loading bar that does not move.

  1. Double clicking the unity package gives this

I am trying to uninstall and reinstall now, to see if that does anything.

Thanks for any responses!

1 Like

Hi @greenreader9 ! Try this steps:

  • Remove the all projects from the “Game Files” folder
  • Open the “Ready maker” and load the your project
  • Tap to “Export To Unity” button
  • Open the “Game Files” folder and create a new one inside folder
  • Select the new folder inside the “Game Files” folder
  • Tap to “Save” and export all files
  • Open the Unity and import the your project (Select the new folder)

It seems to me that Unity is opening another project instead of the one you saved.

1 Like

Ok, so I was able to get the project open in Unity (After about 4 failed try’s) after using you instructions above.

When I go to make a update to the app in Google Play, I get this error message. It doesn’t make sense because the package name is “com.GamesByTroy.TheFlyingEagle.apk”

Thanks again!

1 Like

Hey @Ready, Not sure if you saw my latest response yet.
Thanks for your help!

2 Likes

Hi @greenreader9 ! You made a mistake in the name of the package (In the “Build and Settings” tab), carefully check how you filled in these lines:

Package_name

  • In the “Package name” line you must remove all spaces and separate the names with dots, as well as the name of the company and your game must completely match.
2 Likes

@Ready, Wow! I guess this is what happens when you take a game design break for over 3 months :slight_smile:
I had changed the name in your “1)” image, but apparently “2)” did not change.

So I export and upload (It works!!!), click “save” and NOOOOOOOOOO, the error!

Here it is, it all its red glory:


Learn More

(I added the “Learn More” link from the screenshot)

I was looking around Google, and found that the “ARM64” box should be checked. So I switched the “Scripting Background” to “IL2CPP” and check all the ARM boxes as well as the x86 box. Exported as an .aab, and the error is still there.

I don’t see a 64bit option in build settings either…

What dumb thing did I do now?
Thanks!

EDIT: Solved!
Turns out I have to check “ARMv7” and “ARM64” but NOT “x86” (Took me over an hour to get that right!)

Thanks again for all your help (And for creating an amazing program!)
Greenreader9

2 Likes

Yes, you did everything right :mechanical_arm:, the “x86” platform has already been removed in the latest versions of Unity and will no longer be used.

No problem! :metal:

2 Likes