iPad 2 - is it supported by Ready Maker

I just installed Ready Maker from the App Store. Says it should work on iOS 9.0 and above. I have an old iPad 2 and ReadyMaker crashes just after the splash screen and before the Featured games screen completely loads.

5 Likes

An iPad 2 is a very old iPad and Apple itself no longer supports it.

Ready Maker is more of a complex app with a lot of systems within it.

On the App Store when it says you need a certain iOS version is kind of unreliable since you can have the supported iOS version but it still may crash like what is happening to you

4 Likes

Ipad 2 has 512 mb ram.
There may not be enough ram to run Ready and the IOS.
I tried re-downloading the app Hyperpad on an Ipad 3.
The app says i have to update.
The update option doesn’t appear in the app store.
Probably because the app requires more power to run and the Ipad 3 can no longer run the app.

4 Likes

Thanks for the replies. I figured it might not work, but I couldn’t find a system requirements handy so thought I’d ask. Answers might help others from spending time trying to get it going.

5 Likes

Frustrating, isn’t it? It seems as devices become more and more expensive, their shelf life becomes ever shorter. There’s something to be said for analog “devices”. Like books :slight_smile:

3 Likes