Help! My game is not importing to unity correctly!

Hi everyone!
When I play the game I created in ready, the game works correctly and the borders of the game are in the correct place. however when I import the game to unity, the game seems to shrink. Am I doing something incorrectly? I have tried closing both ready and unity, restating the PC, and re-exporting the game from ready. Can someone please let me know what going on?
Thanks!


In the fist screenshot (from the ready application) the game is properly formatted


In the second screenshot (from unity) the game seems to have shrank (the highlighted area should not be there)

Again, any (and all) help is appreciated!

3 Likes

I don’t know how to solve this off of the Ready Maker app because I have never experienced this when exporting ready projects to unity.

However, you may be able to move things around and increase object sizes in unity to fix this issue

1 Like

Hi, you just need to change the player settings, here:

In any case, this is just playing the scene inside the editor and does not in any way affect the final result that you get after you compile the build for the PC, Android or MAC.

3 Likes

Hi @greenreader9. Your game (as per the screenshot of Ready Maker) looks great! Please make sure to share the game here once you are done with exporting it to Unity

2 Likes

Thanks @Ready. Just to clear up a little confusion, it doesn’t matter what is showing in the unity editor, what matters is what shows when I play the game in ready?

Also, @samsajwani1234 I will be sure to post it when it’s completed!

3 Likes

Hey, Unfortunately @Ready your fix did not work. Please see the included screenshot and let me know what’s happening.
Thanks

3 Likes

Actually, @Ready 's solution worked perfectly. I just forgot to hit play. Please ignore my latest post.
Thanks

4 Likes

Good to hear that your problem is solved @greenreader9!

2 Likes

WOW!!! I just read the instructions from the screenshot. The idea is truly awesome!!! :slightly_smiling_face::slightly_smiling_face:

4 Likes