Full Project failed to export to Unity (NullReferenceException)


#1

So I followed both videos from Ready to export games into Unity and my game cut in half and has missing assets.

Missing textures.

Audio Missing.

Health bars both appearing as a value of 0 instead of 100.

My full level and game is not appearing as it does in Ready.

Zero Gameplay.

When I clicked the error code message it sent me to object “Controller”.

How can I fix this?

I’m on “Unity.2017.3.1p4” version.





#2

Could you make a 30 second video of the game running on Ready and post it to Youtube so i can see how it plays?
I could then try and make a replica or your game using Construct.
Then i can send you a link to download the Construct file and you can open it and see how to code a similar game using Construct.


#3

I wanna have my games built in Ready :slightly_smiling_face:


#4

OK.
If you do end up makng an Android app from using Ready and publish to the Playstore, please advertise your game on the forum and tell about how easy/difficult the process has been.


#5

Hi @James! Just try compile the your game for the windows and check the result (Go to build and settings tab, select Windows platform and tap to the build button). As far as I can see you have turned off the sound when playing and try adjusting the screen size:


#6

Everything is working better then before because I went to Build Settings > Select Windows Platform > Tap Build Button.

Bugs that are left to fix because they affect the main gameplay.

Health Bar has a red trim around it and goes down super fast does not give a chance to play the game with all of the power ups.

Tap to start appears on the screen when the player presses “Play Again Button”.

You’ll see some black textures from out of world.

The game should look like image 2

How it appears

How it should look like


#7

Perfect! Next recomendations:

"Health Bar has a red trim around it " - this is hardly possible to fix without interfering with the settings, so the ideal solution would be to add two new sprites that should hide the red frame. (Draw a sprite that will be empty inside (Frame) and place it on top above the “Life Meter”)

“and goes down super fast does not give a chance to play the game with all of the power ups.” - The fact is that the Unity handles the event faster in which your opponent comes into contact with the player. Add an additional condition to the event to do this, for example:

Player Car/Sensing/Is Touch Object/Enemy Car

and

System/Runtime/Repeat Every/0.1 sec

do

Enemy Life/Life Meter/Subtract/1

“Tap to start appears on the screen when the player presses “Play Again Button”.” - as far as I remember the your project, this same result we have in the “Ready Maker”. This hapines because you restarted the all project. (Check events in the Ready)

“You’ll see some black textures from out of world.” - This is due to the fact that you use the phone screen size in the your project (Landscape/Phone mode 10:6), when you create an apk file, your scene should be displayed correctly on all mobile devices.


#8

More great news everything is working great on my end.

After Three builds I got use to making builds :slightly_smiling_face:

Just one bug left that red trim I mentioned around my life meters I found out what the issue is but can’t fix it.

If you view both images in my last reply you’ll notice that both bars are bigger in W & H then as the intended design is there away in Ready to fix that for Unity?

I have no idea how to draw lol

Because drawing over it will create more issues as it will be over the text of the cars.

But if we can remove that extra W & H from where ever it’s coming from the issue will be fixed :slightly_smiling_face: (I hope)

Once this bug is fixed I can finally publish my video game :slightly_smiling_face:

I really have no idea how to do this

"Health Bar has a red trim around it " - this is hardly possible to fix without interfering with the settings, so the ideal solution would be to add two new sprites that should hide the red frame. (Draw a sprite that will be empty inside (Frame) and place it on top above the “Life Meter”)


#9

Ok so great news everything is fixed but with another way of fixing it.

Took three more builds but I love creating builds in Unity :slightly_smiling_face:

What I did was change the red color trim to grey like the road but slightly different grey because it will be an indicator and it actually looks cool so there’s that.

My idea was lets find a color that matches my level and style of game :slightly_smiling_face:

I tried the sprites with an empty frame on both life meters and it did not work unfortunately.

Thanks for all of your help it’s very appreciated.


#10

No problem :wink:. Congratulations!!!:clap::clap::clap: