4 hours, 3 websites, 2 systems, still no gif

Do they have to be a certain format? Or size? Or magic beans?

Im currently using a frame from the same animation set as my object, and it renders just fine. But the assembled gif is useless, from multiple gif site, and built and imported from my PC and my Android tablet. (I love that i build exclusively on the tablet, yay future!)

Im past frustrated. Why do gifs not work right? It seems the ones that preview with a black background…import correctly viewed, but then display as a red question mark. The ones that dont have a black background, import correctly viewed, but also display as a big red? Also tried different sizes, different speeds…the things the gif making tools allow.

I see in the release notes that you can use the ‘stickers’ from Giphy to add to your scene…is that the big secret? You have to select ‘sticker’ mode? How in the world do i make a sticker? Giphy has them, but they just seem to be gifs? Black magic, im going outside to play with a stick in the dirt, that at least works.:smile:

Its like all the most basic stuff in this is hidden arcane lore you have to search for…fun for a game, not so much for a tool.:thinking:

1 Like

If u reply back with the gif pasted on the forum. I can copy the gif and see if i can help


And certainly, thank you very much for the offer to help. I would still like to know how its going wrong, so i dont keep having the same issue.

1 Like

You know when you click “UPLOAD ASSETS”
the menu says ARTWORK-AUDIO-GIF
Click GIF, then search your PC for the GIF you want to upload.
The UPLOAD option is ARTWORK by default, so if you try to upload a GIF when the ARTWORK option is selected, there will be a red Question mark when you try to upload.
This also happens if you try to upload an image with GIF selected in the options.
Here is the link where i uploaded your GIF to a new project start.
The GIF runs fine without any problems,



I run from mobile, and maybe thats the issue. I also had problems getting my audio in, until i used the pc version, then it went in fine.

I am sure, moatly, that i was selecting gif for my animations, they are all under my gif tab…but i will keep at it.

Thank you so much!



Its fun, kinda hard to win, has enemy that attack, retreat and bleed. The player even gets wounded and slows to a crawl. Had fun, still never once got the stupid gifs working or it would be even cooler.

Thanks Suzzy, yours works great, mine just wont. Maybe i will make a better one next time.

1 Like

I have trouble animating some Gifs i’ve made also.
You’ve done a lot in a short time wtih Ready.
It’s easier and quicker to just use sprites instead of Gifs.
Cool AI you made of attacking and fleeing NPC’s
The player slowing down because of low health is a great idea as well.